PHP-versie instellen

Sommige PHP-scripts werken niet goed onder nieuwe of juist oudere versies van PHP. NederHost geeft u de mogelijkheid om zelf te bepalen welke versie van PHP op uw site draait door dit via Mijn NederHost instelbaar te maken.

De PHP-versie van uw website kunt u instellen via Mijn NederHost, bij de instellingen van uw website. Het duurt maximaal 10 minuten voor uw wijziging is doorgevoerd.

Als u geen acute reden heeft om de PHP-versie te wijzigen laat deze dan op de instelling 'standaard' staan: u profiteert dan automatisch van upgrades die NederHost uitvoert. Voor alle opties geldt dat NederHost eventuele nieuwe revisies (dit is het derde deel van het versienummer) geautomatiseerd zal installeren, tenzij de PHP-ontwikkelaars aangeven dat dingen op niet-compatible wijze zijn veranderd.

Als u dus PHP 5.2 instelt dan zal NederHost dus uw PHP-versie toch automatisch bijwerken van versie 5.2.18 naar 5.2.19 zodra die versie wordt uitgebracht. De reden hiervan is dat deze revisies vaak beveiligingsproblemen oplossen en vrijwel nooit voor problemen zorgen met bestaande scripts.

Let op: voor iedere versie van PHP geldt mogelijk een andere systeemconfiguratie. U kunt eventueel de PHP-configuratie voor uw site aanpassen.

Gerelateerde artikelen

Bestandsrechten en PHP
NederHost maakt gebruik van software om PHP uit te voeren onder uw eigen gebruikersaccount. Dit heeft gevolgen voor het instellen van bestandsrechten.
De configuratie aanpassen
U kunt PHP-instellingen wijzigen met behulp van een eigen .user.ini-bestand.
Probleem oplossen: e-mail verzonden met mail() komt niet aan
NederHost adviseert om de PEAR-module Mail te gebruiken voor het versturen van e-mail; lees hier hoe.